<!DOCTYPE html><html lang="en-US"><head ><meta charset="UTF-8" /><meta name="viewport" content="width=device-width, initial-scale=1" /><meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' /> <!-- This site is optimized with the Yoast SEO plugin v19.10 - https://yoast.com/wordpress/plugins/seo/ --><title>Certain Songs #2494: Stevie Nicks - &quot;Edge of Seventeen&quot;</title><link rel="preconnect" href="https://fonts.gstatic.com/" crossorigin/><link rel="preconnect" href="https://fonts.googleapis.com"/><style type="text/css">@font-face {
 font-family: 'Raleway';
 font-style: normal;
 font-weight: 400;
 font-display: swap;
 src: url(https://fonts.gstatic.com/s/raleway/v22/1Ptxg8zYS_SKggPN4iEgvnHyvveLxVvaorCIPrQ.ttf) format('truetype');
}
@font-face {
 font-family: 'Raleway';
 font-style: normal;
 font-weight: 700;
 font-display: swap;
 src: url(https://fonts.gstatic.com/s/raleway/v22/1Ptxg8zYS_SKggPN4iEgvnHyvveLxVs9pbCIPrQ.ttf) format('truetype');
} </style><link rel="preload" as="font" href="https://fonts.gstatic.com/s/raleway/v18/1Ptug8zYS_SKggPNyC0IT4ttDfA.woff2" crossorigin/><meta name="description" content="Album: BELLA DONNA | Year: 1981" /><link rel="canonical" href="https://medialoper.com/certain-songs-2494-stevie-nicks-edge-of-seventeen/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Certain Songs #2494: Stevie Nicks - &quot;Edge of Seventeen&quot;" /><meta property="og:description" content="Album: BELLA DONNA | Year: 1981" /><meta property="og:url" content="https://medialoper.com/certain-songs-2494-stevie-nicks-edge-of-seventeen/" /><meta property="og:site_name" content="Medialoper" /><meta property="article:publisher" content="https://www.facebook.com/medialoper/" /><meta property="article:published_time" content="2022-11-25T22:42:41+00:00" /><meta property="og:image" content="https://media.medialoper.com/wp-content/uploads/2022/11/18132629/Stevie-Nicks-Edge-of-Seventeen.jpg" /><meta property="og:image:width" content="570" /><meta property="og:image:height" content="578" /><meta property="og:image:type" content="image/jpeg" /><meta name="author" content="Jim Connelly" /><meta name="twitter:label1" content="Written by" /><meta name="twitter:data1" content="Jim Connelly" /><meta name="twitter:label2" content="Est. reading time" /><meta name="twitter:data2" content="5 minutes" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebPage","@id":"https://medialoper.com/certain-songs-2494-stevie-nicks-edge-of-seventeen/","url":"https://medialoper.com/certain-songs-2494-stevie-nicks-edge-of-seventeen/","name":"Certain Songs #2494: Stevie Nicks - \"Edge of Seventeen\"","isPartOf":{"@id":"https://medialoper.com/#website"},"primaryImageOfPage":{"@id":"https://medialoper.com/certain-songs-2494-stevie-nicks-edge-of-seventeen/#primaryimage"},"image":{"@id":"https://medialoper.com/certain-songs-2494-stevie-nicks-edge-of-seventeen/#primaryimage"},"thumbnailUrl":"https://media.medialoper.com/wp-content/uploads/2022/11/18132629/Stevie-Nicks-Edge-of-Seventeen.jpg","datePublished":"2022-11-25T22:42:41+00:00","dateModified":"2022-11-25T22:42:41+00:00","author":{"@id":"https://medialoper.com/#/schema/person/28206ebbe2a8b7c8f51358e59f19cf5c"},"description":"Album: BELLA DONNA | Year: 1981","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://medialoper.com/certain-songs-2494-stevie-nicks-edge-of-seventeen/"]}]},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://medialoper.com/certain-songs-2494-stevie-nicks-edge-of-seventeen/#primaryimage","url":"https://media.medialoper.com/wp-content/uploads/2022/11/18132629/Stevie-Nicks-Edge-of-Seventeen.jpg","contentUrl":"https://media.medialoper.com/wp-content/uploads/2022/11/18132629/Stevie-Nicks-Edge-of-Seventeen.jpg","width":570,"height":578},{"@type":"WebSite","@id":"https://medialoper.com/#website","url":"https://medialoper.com/","name":"Medialoper","description":"We&#039;re Not Who You Think We Are","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://medialoper.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"Person","@id":"https://medialoper.com/#/schema/person/28206ebbe2a8b7c8f51358e59f19cf5c","name":"Jim Connelly","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://medialoper.com/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/902d2eb85b3e4b24f37a253dc7c1d9de?s=96&d=mm&r=pg","contentUrl":"https://secure.gravatar.com/avatar/902d2eb85b3e4b24f37a253dc7c1d9de?s=96&d=mm&r=pg","caption":"Jim Connelly"},"description":"Jim Connelly has been eye-deep in media of all kinds ever since he can remember, and probably prior to that. Over the past quarter-century he has worked in the radio, film, music, and internet industries, and has been writing about popular culture and technology the entire time. Prior to co-founding Medialoper, Jim's work appeared both online and off in publications such as Wired, The Village Voice, Neumu and Websight Magazine . . . Jim at Facebook . . . Jim on Twitter . . .","sameAs":["http://kirkb3.sg-host.com"],"url":"https://medialoper.com/author/jim/"}]}</script> <!-- / Yoast SEO plugin. --><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='stylesheet' id='news-pro-css' href='https://medialoper.com/wp-content/themes/news-pro/news-pro.min.css?ver=3.2.2' type='text/css' media='all' /><link rel='stylesheet' id='wp-block-library-css' href='https://medialoper.com/wp-includes/css/dist/block-library/style.min.css?ver=6.1.1' type='text/css' media='all' /><link rel='stylesheet' id='classic-theme-styles-css' href='https://medialoper.com/wp-includes/css/classic-themes.min.css?ver=1' type='text/css' media='all' /> <style id='global-styles-inline-css' type='text/css'>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</style><link rel='stylesheet' id='dashicons-css' href='https://medialoper.com/wp-includes/css/dashicons.min.css?ver=6.1.1' type='text/css' media='all' /> <script type='text/javascript' src='https://medialoper.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.1' id='jquery-core-js'></script> <script type='text/javascript' src='https://medialoper.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script><link rel="https://api.w.org/" href="https://medialoper.com/wp-json/" /><link rel="alternate" type="application/json" href="https://medialoper.com/wp-json/wp/v2/posts/31109" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://medialoper.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://medialoper.com/wp-includes/wlwmanifest.xml" /><link rel='shortlink' href='https://medialoper.com/?p=31109' /><link rel="alternate" type="application/json+oembed" href="https://medialoper.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmedialoper.com%2Fcertain-songs-2494-stevie-nicks-edge-of-seventeen%2F" /><link rel="alternate" type="text/xml+oembed" href="https://medialoper.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmedialoper.com%2Fcertain-songs-2494-stevie-nicks-edge-of-seventeen%2F&#038;format=xml" /> <script type="text/javascript"><!--
function powerpress_pinw(pinw_url){window.open(pinw_url, 'PowerPressPlayer','toolbar=0,status=0,resizable=1,width=460,height=320');	return false;}
//--> </script> <!-- This code is added by Analytify (4.2.3) https://analytify.io/ !--> <script async src="https://www.googletagmanager.com/gtag/js?id=UA-900695-1"></script> <script> window.dataLayer = window.dataLayer || [];
 function gtag(){dataLayer.push(arguments);}
 gtag('js', new Date());
 const configuration = JSON.parse( '{"anonymize_ip":"false","forceSSL":"true","allow_display_features":"false"}' );
 const UACode = 'UA-900695-1';
 gtag('config', UACode, configuration); </script> <!-- This code is added by Analytify (4.2.3) !--><link rel="icon" href="https://media.medialoper.com/wp-content/uploads/2020/01/16173356/favicon.ico" sizes="32x32" /><link rel="icon" href="https://media.medialoper.com/wp-content/uploads/2020/01/16173356/favicon.ico" sizes="192x192" /><link rel="apple-touch-icon" href="https://media.medialoper.com/wp-content/uploads/2020/01/16173356/favicon.ico" /><meta name="msapplication-TileImage" content="https://media.medialoper.com/wp-content/uploads/2020/01/16173356/favicon.ico" /></head><body class="post-template-default single single-post postid-31109 single-format-standard custom-header header-full-width content-sidebar genesis-breadcrumbs-hidden genesis-footer-widgets-hidden"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0.49803921568627" /><feFuncG type="table" tableValues="0 0.49803921568627" /><feFuncB type="table" tableValues="0 0.49803921568627" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.54901960784314 0.98823529411765" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.71764705882353 0.25490196078431" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.27843137254902" /><feFuncB type="table" tableValues="0.5921568627451 0.27843137254902" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.64705882352941" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.78039215686275 1" /><feFuncG type="table" tableValues="0 0.94901960784314" /><feFuncB type="table" tableValues="0.35294117647059 0.47058823529412" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.65098039215686 0.40392156862745" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.44705882352941 0.4" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.098039215686275 1" /><feFuncG type="table" tableValues="0 0.66274509803922" /><feFuncB type="table" tableValues="0.84705882352941 0.41960784313725" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><div class="site-container"><ul class="genesis-skip-link"><li><a href="#genesis-content" class="screen-reader-shortcut"> Skip to main content</a></li><li><a href="#genesis-sidebar-primary" class="screen-reader-shortcut"> Skip to primary sidebar</a></li></ul><div class="site-container-wrap"><nav class="nav-secondary" aria-label="Secondary"><div class="wrap"><ul id="menu-top" class="menu genesis-nav-menu menu-secondary js-superfish"><li id="menu-item-21967" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21967"><a href="https://medialoper.com/about/"><span >About</span></a></li><li id="menu-item-21966" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21966"><a href="https://medialoper.com/archives/"><span >Archives</span></a></li><li id="menu-item-21965" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21965"><a href="https://medialoper.com/contact/"><span >Contact</span></a></li></ul></div></nav><header class="site-header"><div class="wrap"><div class="title-area"><p class="site-title"><a href="https://medialoper.com/">Medialoper</a></p><p class="site-description">We&#039;re Not Who You Think We Are</p></div></div></header><div class="site-inner"><div class="content-sidebar-wrap"><main class="content" id="genesis-content"><article class="post-31109 post type-post status-publish format-standard has-post-thumbnail category-certain-songs tag-bella-donna tag-edge-of-seventeen tag-stevie-nicks entry" aria-label="Certain Songs #2494: Stevie Nicks &#8211; &#8220;Edge of Seventeen&#8221;"><header class="entry-header"><h1 class="entry-title">Certain Songs #2494: Stevie Nicks &#8211; &#8220;Edge of Seventeen&#8221;</h1><p class="entry-meta"><time class="entry-time">November 25, 2022</time> by <span class="entry-author"><a href="https://medialoper.com/author/jim/" class="entry-author-link" rel="author"><span class="entry-author-name">Jim Connelly</span></a></span> <span class="entry-comments-link"><a href="https://medialoper.com/certain-songs-2494-stevie-nicks-edge-of-seventeen/#respond">Leave a Comment</a></span></p></header><div class="entry-content"><p><a href="https://media.medialoper.com/wp-content/uploads/2022/11/18132629/Stevie-Nicks-Edge-of-Seventeen.jpg"><img decoding="async" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://media.medialoper.com/wp-content/uploads/2022/11/18132629/Stevie-Nicks-Edge-of-Seventeen-296x300.jpg" alt="" width="198" height="200" class="alignleft size-medium wp-image-31110 lazyload" data-srcset="https://media.medialoper.com/wp-content/uploads/2022/11/18132629/Stevie-Nicks-Edge-of-Seventeen-296x300.jpg 296w, https://media.medialoper.com/wp-content/uploads/2022/11/18132629/Stevie-Nicks-Edge-of-Seventeen.jpg 570w" sizes="(max-width: 198px) 100vw, 198px" /><noscript><img decoding="async" src="https://media.medialoper.com/wp-content/uploads/2022/11/18132629/Stevie-Nicks-Edge-of-Seventeen-296x300.jpg" alt="" width="198" height="200" class="alignleft size-medium wp-image-31110 lazyload" srcset="https://media.medialoper.com/wp-content/uploads/2022/11/18132629/Stevie-Nicks-Edge-of-Seventeen-296x300.jpg 296w, https://media.medialoper.com/wp-content/uploads/2022/11/18132629/Stevie-Nicks-Edge-of-Seventeen.jpg 570w" sizes="(max-width: 198px) 100vw, 198px" /></noscript></a></p><p><em>Album: <strong>Bella Donna</strong> <br /> Year: 1981</em></p><p>. . .</p><p>This is probably my favorite Stevie Nicks song all up, and that includes Fleetwood Mac heavy hitters like &#8220;Landslide,&#8221; &#8220;Gold Dust Woman&#8221; and even the hallowed &#8220;Dreams.&#8221; &#8220;Edge of Seventeen&#8221; takes all of the spacey, trancey aspects of her music and rolls them into a single ball of hooky weirdness.</p><p>We talked a bit yesterday about Stevie Nicks&#8217;s friendship with Tom Petty, and that&#8217;s kinda sorta the springboard for &#8220;Edge of Seventeen,&#8221; as Nicks had befriended Petty&#8217;s then wife, Jane, and at some point Jane told Stevie that she and Tom met at the &#8220;the age of seventeen,&#8221; which Nicks heard as &#8220;the edge of seventeen,&#8221; and there we go.</p><p><span id="more-31109"></span></p><p>In a weird way, this origin story is the polar opposite of an early KFSR joke: during U2&#8217;s live version of &#8220;Gloria&#8221; from <strong>Under a Blood Red Sky</strong>, at the end of the breakdown &#8212; and after he&#8217;s already introduced Adam Clayton &#8212; Bono yells <em>&#8220;this is the Edge&#8221;</em> as Edge starts cranking up his guitar for the final chorus, which one of our DJs heard as &#8220;this is the age!&#8221; engendering a bit of confusion on their part.</p><p>ANYWAYS, guitarist Waddy Wachtel also had an origin story for his churning, chugging riff that drove the song: apparently, he lifted it from &#8220;Here Comes The Night&#8221;  by the Police, which, sure, though what Wachtel is doing is far more primal than what Andy Summers was doing, an chugga chugga chugga chugga railroad ride into infinity.</p><p>Which is what I love about &#8220;Edge of Seventeen:&#8221; how primal it sounds at the core, opening with that riff and some Russ Kunkel hi-hat work, as Nicks, flanked by background singers Lori Perry and Sharon Celani starts with the chorus.</p><blockquote><p><em>Just like the white winged dove<br /> Sings a song<br /> Sounds like she&#8217;s singin&#8217;<br /> Whoo-whoo-whoo<br /> Just like the white winged dove<br /> Sings a song<br /> Sounds like she&#8217;s singin&#8217;<br /> Whoo, baby, whoo<br /> Said, whoo</em></p></blockquote><p>So here&#8217;s an embarrassing fact: for years and years and years, I heard that chorus as <em>&#8220;just like the one-winged dove,&#8221;</em> not <em>&#8220;just like the white-winged dove,&#8221;</em> and since I never actually saw a lyric sheet, I don&#8217;t think I ever got corrected with that. Even though I guess a one-winged dove would just fly around in circles, which actually makes sense, given the circular nature of the vocal arrangement.</p><blockquote><p><em>And the days go by<br /> Like a strand in the wind<br /> In the web that is my own<br /> I begin again<br /> Said to my friend, baby (Everything stops)<br /> Nothin&#8217; else mattered<br /> He was no more<br /> (He was no more)<br /> Than a baby then<br /> Well, he seemed broken hearted<br /> Somethin&#8217; within him<br /> But the moment<br /> That I first laid<br /> Eyes on him<br /> All alone on the edge of seventeen</em></p></blockquote><p>As Nicks sings that verse, the musicians start filling it out: Professor Roy Bittan on the piano, most especially, but there&#8217;s also assorted percussion, and of course as they head back into the chorus, drummer Russ Kunkel his some tight, tremendous drum rolls that always start a tiny bit too late but always end up exactly where they belong, as do the backing vocalists, who swoop and swirl all around Nicks: not on the chorus, but basically the entire song.</p><p>While Nicks originally intended to write the song about her friends the Pettys, the deaths of Iovine&#8217;s friend John Lennon and Nicks&#8217;s own uncle turned it into a meditation on grief.</p><blockquote><p><em>The clouds never expect it<br /> When it rains<br /> But the sea changes color<br /> But the sea<br /> Does not change<br /> So with the slow graceful flow<br /> Of age<br /> I went forth with an age old<br /> Desire to please<br /> On the edge of seventeen</em></p></blockquote><p>Of course, I didn&#8217;t know any of this back in 1981, by which time I&#8217;d edged past 17 to the ripe old age of 18; all I knew for sure was that guitar part was really fucking cool, the drum rolls nearly as cool and the harmonies on <strong>&#8220;sings a song sounds like she&#8217;s singing&#8221;</strong> the best of all.  And I wasn&#8217;t the only one: while &#8220;Edge of Seventeen&#8221; didn&#8217;t do nearly as well as the fantastic Tom Petty duet &#8220;<a href="https://medialoper.com/certain-songs-2493-stevie-nicks-and-tom-petty-the-heartbreakers-stop-draggin-my-heart-around/" rel="noopener" target="_blank">Stop Draggin&#8217; My Heart Around</a>&#8221; and the dread Don Henley duet &#8220;Leather and Lace&#8221; (which actually sounds OK now, until Henley starts singing), it still made it to #11 on the Billboard Hot #100.</p><p>And while Nicks had bigger hits as the 80s went on, both &#8220;Stand Back&#8221; and &#8220;Talk To Me&#8221; rode their back-lit videos into the top ten, nowadays, they just sound like generic 80s pop, and I had no time for them even at the time. On the other hand, &#8220;Edge of Seventeen&#8221; sounded amazing back then, and still does, and is easily her most popular solo song on Spotify, having been streamed nearly 320 million times. (In terms of Stevie Nicks songs all up, &#8220;Landslide&#8221; has nearly 500 million streams and &#8220;Dreams&#8221; is now over a billion!)</p><p>Oh, and if the Duffer Brothers are reading this, &#8220;Edge of Seventeen&#8221; should be the next 1980s song you make into a 2020s hit. It would be perfect for the next season of <strong>Stranger Things</strong>.</p><p><strong>&#8220;Edge of Seventeen&#8221;</strong><br /> <iframe class="lazyload" title="Edge of Seventeen" width="500" height="375" data-src="https://www.youtube.com/embed/3oZunnY-Cbs?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p><p><strong>&#8220;Edge of Seventeen&#8221; Original Video</strong><br /> <iframe class="lazyload" title="STEVIE NICKS - EDGE OF SEVENTEEN (Original  Video 1981)" width="500" height="375" data-src="https://www.youtube.com/embed/hSp4F7u7sjY?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p><p><strong>&#8220;Edge of Seventeen&#8221; Live 1981</strong><br /> <iframe class="lazyload" title="Stevie Nicks - Edge of Seventeen (Official Music Video)" width="500" height="375" data-src="https://www.youtube.com/embed/UmPgMc3R8zg?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p><p>Did you miss a Certain Song? Follow me on Twitter: <a href="https://twitter.com/barefootjim"> @barefootjim</a></p><p><b>The Certain Songs Database</b><br /> A filterable, searchable &#038; sortable somewhat up to date database with links to every &#8220;Certain Song&#8221; post I&#8217;ve ever written.</p><p><a href="https://www.obvibase.com/p/KbEcINiF8V8m">Check it out!</a></p><p><b>Certain Songs Spotify playlist</b><br /> (It&#8217;s recommended that you listen to this on Spotify as their embed only has 200 songs.)</p><p><iframe class="lazyload" title="Spotify Embed: Certain Songs" style="border-radius: 12px" width="100%" height="380" frameborder="0" allowfullscreen allow="autoplay; clipboard-write; encrypted-media; fullscreen; picture-in-picture" loading="lazy" data-src="https://open.spotify.com/embed/playlist/70M4k1EAu1HgwU8fkm88g9?utm_source=oembed"></iframe></p><p><strong>Support &#8220;Certain Songs&#8221; with a donation on Patreon</strong><br /> <a href="https://www.patreon.com/barefootjim" target="_blank" rel="noopener">Go to my Patreon page</a></p></div><footer class="entry-footer"><p class="entry-meta"><span class="entry-categories">Filed Under: <a href="https://medialoper.com/category/certain-songs/" rel="category tag">Certain Songs</a></span> <span class="entry-tags">Tagged With: <a href="https://medialoper.com/tag/bella-donna/" rel="tag">Bella Donna</a>, <a href="https://medialoper.com/tag/edge-of-seventeen/" rel="tag">Edge of Seventeen</a>, <a href="https://medialoper.com/tag/stevie-nicks/" rel="tag">Stevie Nicks</a></span></p></footer></article><h2 class="screen-reader-text">Reader Interactions</h2><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply</h3><form action="https://medialoper.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> <span class="required-field-message">Required fields are marked <span class="required">*</span></span></p><p class="comment-form-comment"><label for="comment">Comment <span class="required">*</span></label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" autocomplete="name" required /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" autocomplete="email" required /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" autocomplete="url" /></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='31109' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="00a2a34c7a" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="159"/><script>document.getElementById( "ak_js_1" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form></div><!-- #respond --></main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" id="genesis-sidebar-primary"><h2 class="genesis-sidebar-title screen-reader-text">Primary Sidebar</h2><section id="media_image-2" class="widget widget_media_image"><div class="widget-wrap"><img width="250" height="180" src="https://media.medialoper.com/wp-content/uploads/2019/05/loper-logo.png" class="image wp-image-21962  attachment-full size-full" alt="Lopy" decoding="async" style="max-width: 100%; height: auto;" /></div></section><section id="search-3" class="widget widget_search"><div class="widget-wrap"><h3 class="widgettitle widget-title">Search</h3><form class="search-form" method="get" action="https://medialoper.com/" role="search"><label class="search-form-label screen-reader-text" for="searchform-1">Search this website</label><input class="search-form-input" type="search" name="s" id="searchform-1" placeholder="Search this website"><input class="search-form-submit" type="submit" value="Search"><meta content="https://medialoper.com/?s={s}"></form></div></section><section id="recent-posts-4" class="widget widget_recent_entries"><div class="widget-wrap"><h3 class="widgettitle widget-title">Previously on Medialoper</h3><ul><li> <a href="https://medialoper.com/certain-songs-2494-stevie-nicks-edge-of-seventeen/" aria-current="page">Certain Songs #2494: Stevie Nicks &#8211; &#8220;Edge of Seventeen&#8221;</a></li><li> <a href="https://medialoper.com/certain-songs-2493-stevie-nicks-and-tom-petty-the-heartbreakers-stop-draggin-my-heart-around/">Certain Songs #2493: Stevie Nicks and Tom Petty &#038; The Heartbreakers &#8211; &#8220;Stop Draggin&#8217; My Heart Around&#8221;</a></li><li> <a href="https://medialoper.com/certain-songs-2492-steve-wynn-annie-me/">Certain Songs #2492: Steve Wynn &#8211; &#8220;Annie &#038; Me&#8221;</a></li><li> <a href="https://medialoper.com/certain-songs-2491-steve-wynn-the-miracle-3-no-tomorrow/">Certain Songs #2491: Steve Wynn &#038; the Miracle 3 &#8211; &#8220;No Tomorrow&#8221;</a></li><li> <a href="https://medialoper.com/certain-songs-2490-steve-wynn-the-miracle-3-amphetamine/">Certain Songs #2490: Steve Wynn &#038; The Miracle 3 &#8211; &#8220;Amphetamine&#8221;</a></li></ul></div></section></aside></div></div><footer class="site-footer"><div class="wrap"><p>Copyright &#x000A9;&nbsp;2022 · <a href="https://medialoper.com">Medialoper</a></p></div></footer></div></div><script defer type='text/javascript' src='https://medialoper.com/wp-content/plugins/sg-cachepress/assets/js/lazysizes.min.js#038;ver=7.2.6' id='siteground-optimizer-lazy-sizes-js-js'></script> <script defer type='text/javascript' src='https://medialoper.com/wp-includes/js/hoverIntent.min.js#038;ver=1.10.2' id='hoverIntent-js'></script> <script defer type='text/javascript' src='https://medialoper.com/wp-content/themes/genesis/lib/js/menu/superfish.min.js#038;ver=1.7.10' id='superfish-js'></script> <script defer type='text/javascript' src='https://medialoper.com/wp-content/themes/genesis/lib/js/menu/superfish.args.min.js#038;ver=3.4.0' id='superfish-args-js'></script> <script defer type='text/javascript' src='https://medialoper.com/wp-content/themes/genesis/lib/js/skip-links.min.js#038;ver=3.4.0' id='skip-links-js'></script> <script defer type='text/javascript' src='https://medialoper.com/wp-content/themes/news-pro/js/jquery.matchHeight.min.js#038;ver=3.2.2' id='news-match-height-js'></script> <script defer type='text/javascript' src='https://medialoper.com/wp-content/uploads/siteground-optimizer-assets/news-global-js.min.js#038;ver=3.2.2' id='news-global-js-js'></script> <script type='text/javascript' id='news-responsive-menus-js-extra'> /* <![CDATA[ */
var genesis_responsive_menu = {"mainMenu":"Menu","subMenu":"Submenu","menuClasses":{"combine":[".nav-secondary",".nav-primary",".nav-header"]}};
/* ]]> */ </script> <script defer type='text/javascript' src='https://medialoper.com/wp-content/themes/news-pro/js/responsive-menus.min.js#038;ver=3.2.2' id='news-responsive-menus-js'></script> <script defer type='text/javascript' src='https://medialoper.com/wp-content/plugins/akismet/_inc/akismet-frontend.js?ver=1664405060' id='akismet-frontend-js'></script><script>(function(){var js = "window['__CF$cv$params']={r:'770096ff0cf256ec',m:'7I_6bxoCflh0eNpilUjfE3Q8mHhu5hjEzwZqYXqQfGo-1669444377-0-AW+nyabxk+RcEv6nW5ZZA353vHMa7iezRito3hLO6NNSKBSkUi7DYhc4hSaJMfKWR0HFJhcrgJXCV/T0yWNpZrRU6ko2t/j/fiVFGgTHWFatGYT8dTeLUvyBU+2UY3m71UGaFLc9AN9rO9SRrvVgIrQ1MIm7ZDyzPhujpfMYv4nd8PRFNVWzmky9iDC133Lpdg==',s:[0x161f161a24,0xe6cfced100],u:'/cdn-cgi/challenge-platform/h/b'};var now=Date.now()/1000,offset=14400,ts=''+(Math.floor(now)-Math.floor(now%offset)),_cpo=document.createElement('script');_cpo.nonce='',_cpo.src='/cdn-cgi/challenge-platform/h/b/scripts/alpha/invisible.js?ts='+ts,document.getElementsByTagName('head')[0].appendChild(_cpo);";var _0xh = document.createElement('iframe');_0xh.height = 1;_0xh.width = 1;_0xh.style.position = 'absolute';_0xh.style.top = 0;_0xh.style.left = 0;_0xh.style.border = 'none';_0xh.style.visibility = 'hidden';document.body.appendChild(_0xh);function handler() {var _0xi = _0xh.contentDocument || _0xh.contentWindow.document;if (_0xi) {var _0xj = _0xi.createElement('script');_0xj.nonce = '';_0xj.innerHTML = js;_0xi.getElementsByTagName('head')[0].appendChild(_0xj);}}if (document.readyState !== 'loading') {handler();} else if (window.addEventListener) {document.addEventListener('DOMContentLoaded', handler);} else {var prev = document.onreadystatechange || function () {};document.onreadystatechange = function (e) {prev(e);if (document.readyState !== 'loading') {document.onreadystatechange = prev;handler();}};}})();</script></body></html>